Start doing the shopping cart and run into a really stupid mistake

August 21, 2015 05:15 UTC Team RubyGirls Quito [2015]Subscribe to this teams's activities

Sofi:
Today was a fun day:
1. Spent time at TW office: paired with a programmer to plan what to do in Rails Girls Quito 2015! Learnt with him a lot about databases (sqlite mostly), got my first C lesson (just for fun) and found out how to print 'hello world' with Brainfuck (a programming language): ++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
2. Started doing the shopping cart for implementing Braintree. Tried to migrate with mysql2 gem and failed. Run into two errors: the infinite loop (https://github.com/brianmario/mysql2/pull/654) and forgetting that I needed to start server in order to migrate (http://stackoverflow.com/questions/32129819/install-mysql2-v-0-3-19-via-bundle-gemfile-on-rails). After trying many things (installing and uninstalling with brew, changing path, etc.) and asking for help, I realized I just needed to 'mysql.server start'.
3. Create a presentation and help-cards for Rails Girls Quito 2015. Review documentation on installing Rails and on how to create a first app.

:)

Evy:

Again: "Looks like your app's ./bin/rails is a stub that was generated by Bundler.(Solved). run server with: bundle exe rails s
Learning CouchRest Model https://github.com/couchrest/couchrest_model
Looking for the code related to data base in the app.
Try: rails exe generate controller home index (it doesn’t work).
Starting with curl https://raw.githubusercontent.com/Seppone/openshift-rbenv-installer/master/bin/rbenv-installer (not finish yet)
Notes: For CouchRest Model they recommend Ruby 2.0+ but the app uses 2.0-

Comments

You must be logged in to add a comment.